Posts Tagged ‘users’


In this topic, we are going to discuss the CREATION OF USERS IN FATWIRE. To create a user in Fatwire, you need to login with ADMIN Credentials. Users can be created in Fatwire using ADVANCED UI, and the WEM UI. We are going to learn how to create the users in ADVANCED UI of FATWIRE.

CREATION OF USERS IN FATWIRE:

1. Login to the ADVANCED  UI with Admin credentials.

2. Go to the ADMIN tab of the Advanced UI.

3. Expand “CONTENT SERVER MANAGEMENT TOOLS“. After expanding this, you will be able to see SITE, ELEMENT, ACLs, USER, etc.

4. Double click on USER. The following screen appears. In this screen, as shown below, we can MODIFY USERS, ADD USERS, DELETE USERS, MODIFY USER ATTRIBUTES.

5. Enter a name for the user in the ENTER USER NAME field. This name will be the login username for the new user.

6. Click on ADD USER radio button.

7. Click on the OK button. The following screen appears.

8. Assign the ACCESS PRIVILEGES for the user, as required.

9. Enter the PASSWORD, and re enter the same in RE-ENTER PASSWORD field.

10. Click on the ADD button.

That’s it.. A NEW USER IS CREATED IN FATWIRE.

Advertisements

When we create a site in alfresco share, and start inviting users to the site, the following error will be displayed “0 invites sent, 1 failure”.  This message leaves us to a bit of frustration, after creating sites, users, and when thinking of inviting users to the sites. This article gives the resolution for such a type of error message.

This error occurs because, the Outbound E-mail Configuration has not been set in alfresco-global.properties file. The quick turnaround for this issue would be to add a few lines of code to the alfresco-global.properties file, and add another file outboundSMTP-context.xml, if it doesn’t already exist.

Add the following to alfresco-global.properties file:

//Add to the end of alfresco-global.properties file
# Email settings mail.host=smtp.1and1.com mail.port=465 mail.protocol=smtps mail.username=XXX mail.password=XXX mail.encoding=UTF-8    mail.smtps.auth=true mail.smtps.starttls.enable=true
//END

If a file named outboundSMTP-context.xml doesn’t exist in C:\Alfresco\tomcat\webapps\alfresco\WEB-INF\classes\alfresco\subsystems\email\OutboundSMTP folder, then add the following file and name it as outboundSMTP-context.xml

//  <bean id="mailService">          <property name="host">              <value>${mail.host}</value>          </property>          <property name="port">             <value>${mail.port}</value>         </property>       <property name="protocol">         <value>${mail.protocol}</value>      </property>          <property name="username">              <value>${mail.username}</value>           </property>         <property name="password">              <value>${mail.password}</value>         </property>          <property name="defaultEncoding">             <value>${mail.encoding}</value>         </property>       <property name="javaMailProperties">          <props>               <prop key="mail.smtps.auth">${mail.smtps.auth}</prop>             <prop key="mail.smtps.starttls.enable">${mail.smtps.starttls.enable}</prop>          <prop key="mail.smtp.socketFactory.port">${mail.smtp.socketFactory.port}</prop>          <prop key="mail.smtp.socketFactory.class">${mail.smtp.socketFactory.class}</prop>           <prop key="mail.smtp.socketFactory.fallback">${mail.smtp.socketFactory.fallback}</prop>          </props>      </property>     </bean>

Now, restart alfresco and try inviting users. After inviting the users in share, it should display the following message “1 invites sent, 0 failure”.